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INTRODUCTION

This tutorial was originally written by Luca Lutterotti, Roman Vasin, and Hans-Rudolf Wenk and can be 
found at http://eps.berkeley.edu/~wenk/TexturePage/MAUD.htm along with the companion paper: 

L. Lutterotti, R. Vasin & H.-R. Wenk. Rietveld texture analysis from synchrotron diffraction images. 
I. Calibration and basic analysis (2014) Powder Diffr. 29 76-84 doi: 10.1017/S0885715613001346 

It was updated by S. Merkel at Univ. Lille France, with additional figures and up-to-date screenshots. The 
text was modified following student feedback and failures to follow the instructions during training labs at 
Univ. Lille. The original version also used a detector geometry which is considered obsolete in MAUD. This 
version uses the commended Inclined Detector Geometry.

The Lille version of the tutorial is available at http://merkel.texture.rocks/Cours/MAUD/ 

DOWNLOAD SOFTWARE AND DATA FILES

The latest version of MAUD can always be found at 
https://luttero.github.io/maud/. MAUD is written in Java 
and works with any operating system for which a Java 
implementation is available (Windows, Mac OS X, 
Linux, and Unix). 

You will also find

• MAUD-2025-PartI-CeO2.zip which contains:
◦ Starting files

▪ Diffraction image for CeO2 standard: 
CeO2-00010.tif

▪ Crystallography information file (crystal 
structure) for CeO2: CeO2.cif

◦ Final solutions:
▪ Refined instrument parameters for CeO2: 

APS-BESSRC-11-ID-C-
InclinedReflection.ins

▪ MAUD parameter file for CeO2 with 
completed analysis with a 2025 MAUD 
version and the inclined detector 
geometry (for checking your attemps): 
CeO2_2025_calibration_final.par

• MAUD-2025-Part-I-Coin.zip which contains:
◦ Diffraction images for Nickel coin: 

Nickel-00178-40.tif Nickel-00179-20.tif, 
Nickel-00180-0.tif, Nickel-00181+20.tif, 
Nickel-00182+40.tif

◦ MAUD parameter file for Nickel coin with completed analysis with a 2025 MAUD version and 
the inclined detector geometry (for checking): NCoin_2025_06.par

EXPERIMENT AND OBJECTIVES

A basic configuration for X-ray diffraction experiment, which we will use below, is shown in Figure 1.
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A note on file extensions

MAUD analysis relies on several types of files. 
Please be rigorous and pay attention to those. 
You will be lost in you data analysis if don’t.

• Diffraction images, from the 
experiment, are often saved in  
“TIF”

• The raw data (the diffraction image), 
converted to MAUD format, will use 
“ESG”. Those are MAUD-specific 
plain text files, which you can explore 
with a text editor.

• Crystal information are saved in “CIF”. 
A plain text file defined by the 
International Union of Crystallography.

• MAUD analyzes are saved as 
“PAR”. This is a MAUD-specific 
plain text format which includes all 
information about the analysis, the 
raw data, the cif information for all 
phases in your sample, and the 
physical model used to fit the data.

http://eps.berkeley.edu/~wenk/TexturePage/MAUD.htm
https://www.iucr.org/resources/cif
https://www.iucr.org/resources/cif
http://merkel.texture.rocks/Cours/MAUD/
https://luttero.github.io/maud/
http://dx.doi.org/10.1017/S0885715613001346
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The sample properties are measured using X-ray diffraction, on a detector placed away from the sample. We 
are interested in analyzing the diffraction pattern (intensity as a function of 2θ) but how the diffraction 
pattern changes with the azimuth angle η. All contain information on the crystal structure (atomic positions, 
crystal symmetry, cell parameters, etc) but also microstructural features (grain size, strain, texture, etc). 

Before you start looking at the sample properties, however, you need to know the properties of your 
instrument:

• the characteristics of the your X-ray source: wavelength, spatial distortion, etc,
• your detector:

◦ where it is, in distance, but also whether it is tilted, etc,
◦ whether it induces a specific peak shape, which is not related to sample properties.

The first section of the tutorial will guide you on how to define the properties of your instrument, using data 
measured on a CeO2 standard for which you know all sample properties. The calibrated instrument can then 
be used to study the actual sample you are interested in.

The second section will guide you through the analysis of a real dataset. Part II is optional. You will be 
working on another dataset in the following lesson.

PART 1: STEP-BY-STEP PROCEDURE OF IMAGE PROCESSING AND INSTRUMENT 
CALIBRATION WITH CEO2 STANDARD

When you run MAUD for the first time, a window will open with many options and displays as shown in 
Figure 2. It has three main tabs (left side, top): “Datasets”, “Phases” and “Sample”. 

Most frequently used commands are present as icons in the toolbar, e.g., “Disk” to save current analysis, 
”Eye” to edit a selected object, “Calculator” to compute model diffraction patterns, “Hammer” to start a 
refinement, etc.

Please take some time to explore the MAUD interface, the three tabs for Datasets, phases, and sample. Test 
the effect of the Eye, Calculation, and Hammer icons.

1. Defining the instrument

An instrument is defined for each dataset. 

• Select the default dataset under “Datasets” and edit it (menu: “EditEdit object” or click the “Eye” 
icon in the toolbar). 

• Locate “Diffraction Instrument” in “Instrument” panel under “General” tab.
• Click “Edit” button. This opens the Instrument editing window (Figure 3)

Step by step preparation of the instrument:

• Rename the instrument to “APS-BESSRC 11-ID-C” so you can add it later to the instrument database 
and recognize it when needed.

• Adjust “Incident intensity” value to 0.001.
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Figure 1: Experiment geometry
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• Check that the option for “Intensity calibration” is “none cal”.
• Choose as “Angular calibration” model:

◦ Choose “Inclined Reflection Image”; 
◦ Click “Options” button next to it and 

▪ Change the “Detector distance” to 1850 mm. The distance is needed for the conversion of 
image coordinates to 2; for now it is just an estimate and this value will be refined later.

▪ Set the “Center x error” and “Center y error” to 0
▪ Set all detector angles to 0 (“Detector 2theta”, “Detector tilt”, “Detector rotation”, 

“Detector eta”)
▪  All will be optimized during the tutorial by a calibration model.

• For “Geometry” choose “Image 2D”.
• For “Measurement choose “2Theta”.
• For “Source”:

◦ Select “Synchrotron”, 
◦ Click “Options” and change default wavelength to 0.10798 (Å).

• In “Instrument Broadening” we should set the default parameters to be in line with synchrotron 
diffraction!
◦ Click “Options” button next to the “Caglioti PV” model (Caglioti et al., 1958) 
◦ Remove all asymmetry parameters (or set them zero)
◦ Under “HWHM” tab set all parameters to zero except for the first (the constant value, equal to W 

of the Caglioti formula), set it equal to 0.00025.
• Close the Instrument editing window.
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Figure 2. Main MAUD window on computer running Linux in 2024. Superposed is a window 
“DataFileSet” with options and settings for the selected Dataset. At the start the plot window is 
blank. Here data for CeO2 standard have been entered but not refined.



Université de Lille Master de Physique Advanced Characterization II
MAUD tutorial – 2025/11 version

2. Entering 2D image data

With the ImageJ plugin embedded in MAUD a .tif image file can be directly entered into MAUD and saved 
as .esg files, which are ASCII files containing a list of radial positions or diffraction angles and 
corresponding experimental intensities. If the diffraction data is in another detector format not recognized by 
ImageJ, it has to be converted into a regular .tif file, preserving the original intensities.

To perform the integration in MAUD using the ImageJ library:

• Remain in the “Datasets” window, select “Datafiles” tab (Figure 4)
• Press the button “From images..” to start the ImageJ plugin. 
• A small window with the typical ImageJ toolbar will appear (Figure 5, top right).
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Figure 3. “Diffraction Instrument” window with general setup for synchrotron diffraction images.

Figure 4. “Datafiles” in Dataset options window for CeO2 standard, viewing five of the 
diffraction patterns (.esg file) in the insert. Initially there are no data in the window. The 
screenshot has been taken after they have been loaded “From images”.
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Step by step conversion of a Tif image to MAUD own ESG format:

• From the ImageJ menu “File→Open…” load the image CeO2-00010.tif.
• From menu “Image→Adjust→Brightness/Contrast” use the “Auto” button as many times as you 

need, until you can see clearly also weaker diffraction circles or spots. Close this window.
• Select “Image→Properties”, change “Unit of length” to mm and “Pixel width” and “Pixel height” to 

0.2 for the Perkin-Elmer detector (200 μm/pixel) and press “Ok”. Now on the top of the image 
window you should read “409.60x409.60 mm (2048x2048); 32-bit; 16MB”.

• Next we have to rotate the image 90° to bring the rotation axis for sample tilt into the origin to 
conform to the angle convention in MAUD (Figure 5). Select “Image→Transform→Rotate 90 
Degrees Anticlockwise”. When using later the calibration done with this standard we have to apply 
the same rotation to all sample images.

• Now proceed to the “Plugins→Maud plugins→Multi spectra from normal flat reflection image”. The 
diffraction image appears as illustrated in Figure 5 (left) and next to it a “Choose the integration 
lines” window shows a list of parameters (Figure 5, right). For this sample, 
◦ Sample-Detector distance is 1850 mm. 
◦ Adjust the tracker radius to 2θ = 5 degrees and update the plot (click “Apply” not “OK” to view 

changes). Update it to 7 degrees and click again. Update it to 10 degrees and click again. The 
tracker is indicating where MAUD thinks where a Debye-Scherrer cone with the selected 2θ 
should be on the detector. It is just a visual indication.

◦ If necessary adjust “Center X (mm)” and “Center Y (mm)” to bring the tracker circle (red) into 
the center (the solution is X = 204.85 and Y = 204.79). 

◦ Set the “Eta step” value to to 5°. The image will then be integrated in 72 sectors of  5° each, with 
the azimuth η from 0 to 360° (or -90° to +270° in some cases). The start of the integration is 
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Figure 5. ImageJ setup for image processing to generate diffraction patterns by azimuthal 
integration of the 2D image. The start of the azimuth η (diffraction pattern #0) is indicated. The 
red circle is used for aligning the center of the image. The image will be integrated into azimuthal 
slides. Here, 72 slices of 5°, from 0 to 360° (or -90° to +270° in some cases).
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indicated on Figure 5 (left) and the sense is counterclockwise. 
◦ Set the “2theta step” to 0.01° (otherwise, you will not have enough resolution in 2θ)
◦ Set Sample omega to 90° to bring the normal to the sample into the center of the pole figure (see 

later and Figure 5).
◦ Have the other parameters set to 0. 

• Hit “OK” and the integration should start right away. After the integration is done, the program will 
ask to save the files as ASCII data. Choose the directory in which you have your data and want to 
perform the analysis (better not the MAUD directory). Here we give it a name CeO2-00010 (it is 
good practice to use the same name as the image) and the program will automatically assign “.esg” 
as file extension.

• Close the diffraction image and ImageJ windows and return to the MAUD dataset editing window, 
where the .esg files are now listed in the “Spectra list” panel. If you close the dataset window, a 
summation of all patterns should be visible in the plot panel of the main MAUD window (Figure 2).

Now is a good time to save. Use “File → Save analysis as” and save it to “CeO2_calibration_01.par”. Do 
not just “Save analysis” because this would overwrite the default MAUD parameter file in a random location 
of your computer. Your parameter file contains all information about instrument, phase and sample 
parameters and can be used as a starting analysis file for other images.

3. Refinement range and background

There are no diffraction peaks at 2 < 1.6°, so we restrict the refinement range in the “General” tab of the 
dataset editing window (Fig. 2, insert) by changing “Min in data units” and “Max in data units” values. Units 
are those of the actual diffraction data (in this case 2θ in degrees). Enter 1.6 as Min and 8 as Max.

Be sure to enter both the Min and the Max values. Otherwise, you might get a black screen.

Choose the background model (switch to “Background function” tab). By default a polynomial background 
is used in MAUD, and we use 5 parameters to approximate background by a 4th order polynomial (click “Add 
parameter” or “Remove parameter” buttons to change the number of parameters to 5). 

With this the initial setup of the diffraction instrument and the input of diffraction data is completed

Save your analysis to “CeO2_calibration_02.par”.

4. Phase and initial parameters adjustment

Crystal structure

The “Phases” tab in main MAUD window contains crystallographic and microstructural information on all 
the phases in the sample such as lattice parameters, space group symmetry, atomic positions, grain size, 
texture, etc. By default it is empty. The basic parameters can be entered as “crystallographic information 
files” (.cif) which can be downloaded, e.g., from databases like the ICSD (ICDD) or the COD 
(http://www.crystallography.net, Gražulis et al., 2009) or AMCSD 
(http://rruff.geo.arizona.edu/AMS/amcsd.php, Downs and Hall-Wallace, 2003). 

To import a structure from a .cif file click the “Cylinder with arrow out” icon on the toolbar or select 
“Edit→Load object from CIF…” menu. 

A structure model can also be built manually. Then, navigate through the tabs to define your crystal 
structure  parameters  (space  group,  cell  parameters,  atomic  positions,  etc).  The  procedure  is 
described in the box but not required here.

Here we import the provided cerium oxide structure file CeO2.cif. After it is loaded, edit the CeO2 phase. In 
its properties window switch to “Microstructure” tab, and click “Options” button next to “Size-Strain model: 
isotropic”. There set the crystallite size and microstrain values to 5000 (Å) and 1.0E-5 (in means very little 
peak broadening from the phase, which has been fabricated to do so).

Calculation and visualization

After having entered all this information, pressing the “Calculator” button (or from menu 
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http://www.crystallography.net/
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“Analysis→Compute spectra”) in the main page 
(Figure 2) computes diffraction patterns based on 
user-provided instrumental and phase parameters 
and compares them with experimental data. 

The results of the calculations can be viewed 

• With the “Plot” tab above the pattern in 
MAUD main window which is an average 
over all patterns from a dataset, or,

• With the “Plot 2D” tab in which a stack of 
all individual 72 patterns is displayed 
(experimental patterns are at bottom and 
model patterns are on top). 

For diffraction data a square root scale for intensity 
is quite useful, as smaller peaks are more visible. 
This can be set or changed in “Graphic→Plot 
options” menu.

Save your analysis to “CeO2_calibration_03.par”.

Manual parameters adjustment

Next we want to adjust the scale factor (beam 
intensity in MAUD) as the calculated intensity data 
are different from experimental values. This can be 
done “live” by using the parameter list at the 
bottom of the main MAUD window (Figure 2). 
Enlarge the tree-table and scroll until you see the 
parameter “_pd_proc_intensity_incident” under 
instrument in the dataset. Make sure the column 
“Value” of the table is sufficiently large by 
dragging its border if necessary. Click on the value 
of the parameter you want to change (one click). 
Two arrows and a field to the right of the parameter 
appear. The text field contains the increment by 
which you can change the parameter by clicking on 
corresponding arrows. The updated plot is 
displayed right away. After finishing adjustments 
click the mouse anywhere in the tree-table (except 
a value) to exit from the “editing” mode. 

Then adjust the first background parameter “_riet_par_background_pol0” in the same way.

Save your analysis to “CeO2_calibration_04.par”.

5. Numerical optimization: ‘refinement’ procedure

There are various ways to refine the parameters:

• For a manual refinement the user goes through all relevant parameters listed in the tree-table in the 
bottom part of the MAUD main window and changes their status from “Fixed” to “Refined” (or 
“Equal to…” to set a linear dependence between different parameters). This is quite cumbersome and 
only applicable for experienced users. Some parameters are correlated, and some have very low 
impact on the calculated diffraction pattern unless other parameters values are correct, and the 
refinement has to proceed in a systematic order. 

• The parameters can also be viewed by editing objects under “Datasets”, “Phases” and “Sample” 
tabs. This is more intuitive because there the parameters are illustrated within their context, and with 

Sébastien Merkel Page 8/15

Build a structural model by hand (not required 
here)

• While on “Phases” tab click the icon with 
the picture of a box in the toolbar (or 
select “Edit→Add new object” menu).

• In the “Phases” list “Phase_x” appears. It can 
be renamed by double clicking on it.

• Select the desired phase and “Edit” it.
• In “General” tab enter space group, and 

lattice parameters (for monoclinic structures 
first setting has to be used and for 
rhombohedral lattices, hexagonal setting 
needs to be used to comply with texture 
analysis conventions).

• In “Structure” tab add atomic sites to create 
the structure. Once a site is added, the name 
can be changed by double clicking the entry 
in the list.

• For each site, the atom type can be changed 
by clicking “Atom type” and selecting the 
appropriate atom from the Periodic table that 
will appear. It is possible to select the 
oxidation state (meaningful for x-ray 
scattering only) or isotope (for neutron 
scattering only).

• Adjust atom coordinates, site occupancies, 
ionization state and thermal factors if needed. 
Sometimes thermal factors (especially 
anisotropic) are loaded incorrectly from 
the .cif file. Check them after you import a 
structure.

• The created structure can be viewed in 3D 
by clicking the “Pointer finger” icon in 
the upper right corner of the structure tab 
window.
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a right-click on the parameter you can also set it to “Refined” or “Fixed”. Once you have set all the 
parameters you want to refine, click the “Hammer” (sometimes transforms to “Cash register”) icon 
in the toolbar of the main page (or select “Analysis→Refine” menu).

• Semi-automatic refinement is possible if the user selects the “Analysis→Parameters list” menu, 
which again displays the parameters list (click “Expand all” button below to see the entire tree-table 
of parameters expanded) but at the bottom there are “Commands” that allows user to change certain 
groups of parameters. A good start is to first “Fix all parameters” and then proceed with, e.g., “Free 
scale pars” (general intensities and phase volume fractions are set to “Refined”), “Free 
backgrounds” (all parameters for backgrounds are set to “Refined”), etc. in cycles.

• Automatic refinement is yet another way. For this option click the “Light bulb” icon in the toolbar 
(or go to “Analysis→Wizard” menu) to open “Refinement wizard” and proceed with refinement from 
top to bottom of the list on the left side, or a complete analysis on the right side. But there is no 
wizard option for instrument calibration as it can not be standardized. Calibration should never be 
done with the Wizard (you are guaranteed to be wrong). Even later, you should know what you do 
and exercise caution with the Wizard options.

The refinement can be lengthy, depending on the complexities (number of patterns, number of diffraction 
peaks per pattern, utilization of complex texture/microstructure models, etc.). Do not change anything during 
the optimization of a refinement! If you are reviewing some parameters in the course of the refinement, it is 
important to close all frames using the window close button (on all systems it is the button on the window 
title bar) and not with the “OK” button. The latter changes or refreshes the parameters in midst of the 
refinement and may cause the optimization to behave erratically.

6. Refine scale factors and background

We proceed with the mixture of semi-automatic and manual refinements:

• Start with “Analysis→Parameters list” and first click “Fix all parameters”, then “Free 
Backgrounds” and “Free scale pars”. You may leave parameters list window open to return to it 
later. 

• In the MAUD main window click the “Hammer” button in the toolbar and the least squares 
refinement will start. Choose the number of cycles with the slider appearing at the left side of the 
window (usually 3-5 is sufficient). 

• If the refinement goes well, the calculated and experimental patterns on the display should become 
more similar (dots are experiment, line is model). 

Save your analysis to “CeO2_calibration_05.par”.

7. Refine instrument parameters

Detector location

Next we refine instrument parameters. 

• Edit “Dataset→Diffraction Instrument”. 

• Under “Options” for “Inclined reflection image” right click consecutively on values in red fields for 
the “Detector Distance”, “Center x error”, “Center y error”, “Detector 2theta”, “Detector tilt” and 
select “Refined” in each appearing popup menu. Close the windows and run the refinement again. 
This will adjust the reflection positions.

• Do not adjust “Detector rotation” or “Detector eta”. They are fixed to zero here.

Save your analysis to “CeO2_calibration_06.par”.

Peak broadening due to the instrument

Then it is necessary to refine the instrument broadening parameters in the “Caglioti PV” model. Caglioti 
parameters describe instrument broadening, especially peak asymmetry, peak width and Gaussian plus 
Lorentzian mixing parameter (Caglioti et al., 1958). These instrument peak shape parameters are essential if 
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you want to assess peak shape effects of real samples, such as crystallite size and microstrain, or estimate 
dislocation density and stacking fault probability.

Caglioti parameters are very sensitive and a strict order needs to be followed. We describe the procedure for 
synchrotron image data where the 2θ range is limited. With the initial parameters set as suggested in step 1, 
there should be no need for manual adjustments.

If you feel (or discover during the refinement) that it is still necessary, then start adjusting the first HWHM 
parameter – “_riet_par_caglioti_value0” – manually by using the parameter tree list in the bottom of the 
main window with the “live” procedure (step 5). After that you may adjust the second and if necessary (for 
large 2θ range) the third HWHM to get an approximate fit. You can view an enlarged peak by selecting an 
area in the plot by mouse click and dragging. Afterwards you may return to full pattern view by double 
clicking in the plot or right-clicking and choosing “Reset scale” from popup menu. If you need to adjust the 
asymmetry, then for synchrotron diffraction data we advise to start with only one parameter 
(“_riet_par_asymmetry_value0”) and enter a large value (> 5000) for it if the asymmetry is small (which is 
usually the case for synchrotron data).

After this manual adjustment, you can proceed in the following order (3 iterations are sufficient in each of 
these steps; do not fix the parameters already set refined in previous steps or from beginning and be sure not 
to refine things like wavelength or parameters of the CeO2 phase):

 “_riet_par_caglioti_value0”, set refined and refine.
 “_riet_par_caglioti_value1”, “_riet_par_gaussian_value0”, “_riet_par_gaussian_value1” set 

refined and refine.
 You may add “_riet_par_caglioti_value2” and “_riet_par_gaussian_value2” for a final 

improvement.

Save your analysis to “CeO2_calibration_07.par”.

8. Final step: B-factors

If you look at the plot window you can see that peak intensities sometimes remain poorly fit. You can refine 
an overall thermal factor 

• “Edit” the phase, 
• Switch to “Structure” tab, 
• Right-click on the value of “B-factor” for each atom position.

At this point, if you used the dataset of the tutorial, you should be ready with a decent calibration (Fig. 6).
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Figure 6. Plot view of the CeO2 pattern after the end of the calibration procedure. Data (in black) 
and model (in red) should look identical. Similar match must be obtained in the Plot2D view.
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9. Saving the calibration results

In the end, the calculated peaks should fit the experimental peaks very well, both in the “Plot” and “Plot2D” 
displays (Figure 2). Be sure to save the parameter file at end:

• Open with “Analysis→Parameters list” and select “Fix all parameters”. This will avoid messing up 
the calibration if you re-open the file.

• Save your analysis as “CeO2_calibration_final.par”.

You can also decide to export the instrument for use in the refinement of other samples, “Edit” the current 
datasets and under “General” tab click “Store…” button in the “Instrument” panel to save the instrument 
settings as a separate file in your directory (e.g. giving it a name such as APS-BESSRC-11-ID-C-
InclinedReflection.ins).

We have now refined the relevant instrument parameters with the CeO2 standard and can apply them to other 
samples measured under identical conditions.

10. Exporting the figure

As for the 2D plot (with colors) the best option is to select “Graphics → Mapplot of the selected dataset”. 
Adjust the color range, X-axis scale (2θ, d-spacing, or Q), Y-axis scale (linear, sqrt, log, etc) to your liking. 
Take a screenshot. Load the screenshot in a smart software such Inkscape to fix axes labels, legends, etc.

If you want to switch to grayscale in 2Dplot from color, this is done by selection “Analysis → Preferences”, 
search for “multiplot2D.grayscale” and set it to “true”.

As for the standard plot (i.e. Fig. 6), you can either

• Take a screenshot of the MAUD plot (which is what most people do).
• Export the data and fit for replotting in your favorite software.

To export the data and fit

• Open the Datafiles tab of your dataset
• Select “View summed” among the buttons at the bottom of the window
• Select “Tools → Export from plot” for a simple export of the data and fit in the plot
• Select “Tools → Export experimental / computed data” for a more thorough (and useful) text export 

with the experimental data, the computed data, as well as values of background and diffraction 
intensities for each phase.

ADDITIONAL NOTE: TEXTURE AND LE BAIL ANALYSIS

Sometimes, the diffraction of your calibration standard will show texture or grains. In such case, an 
additional step is necessary, either using a true texture model, or a Le Bail fit.

1- Fit of a true texture model

Texture is fit the “Advanced models” tab for the phase of interest (here CeO2). We will not discuss the full 
tricks of a texture analysis in MAUD, which is beyond the scope of this document, but here is a quick 
tutorial on how to proceed:

• Open the “Advanced models” tab for the phase of interest (here CeO2).

• Select “E-WIMV” from the drop-down list and press the “Options” button next to it. 

• In “E-WIMV options panel” select 10° for “ODF resolution in degrees” (which would require a 
whole discussion).

• Open the “ EWIMV advanced options” and make sure “Normalize pole figures” is  unchecked.

• Click “OK” and close the all windows.

• Run a refinement. It should fit the texture and improve the correspondance between the simulated 
and experimental data, particularly in the Plot2D view. 
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2- Le Bail analysis

If your sample has many grains, you may decide to go for a  Le Bail fit, for which peak intensities are 
matched to fit the data, whatever it means. This will lead to nice looking results but pay attention that when 
Le Bail is activated

• peak intensities have no meaning.
• Beam intensity should be fixed.
• B-factors will be off.
• Phase proportions can not be studied, since peak intensities have no meaning.

To do so, “Edit” CeO2, switch to “Advanced models” tab and select “Arbitrary tex” as texture model. Next 
fix all the scale factors or intensity-related parameters as they are not needed with the Le Bail fitting (set 
fixed the “_pd_processing_intensity_incident” and the “_atom_site_B_iso_or_equiv” for the Ce1 atom site). 
Perform another refinement cycle.

This should drastically improve the visual match between model and data.

Sometimes after the refinement a message “Cholesky negative diagonal” appears in the MAUD output panel. 
This means the problem that MAUD was trying to solve was ill-conditioned, and some of the parameters are 
not refinable at the given conditions. The first of the three displayed numbers refers to the “wrong” 
parameter. You can view it on the MAUD output file (with .lst extension) or you may review the parameters 
list window and find a refined parameter with value “-1” in the “Error” column. After determining the 
parameter you should either adjust it manually or refrain from refining it.
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PART 2. STEP-BY-STEP PROCEDURE FOR TEXTURE ANALYSIS OF NICKEL COIN

1. Introduction

This is a more advanced tutorial, for those who wish to learn how to deal with data involving multiple 
detectors, or data collected on the same detector, with multiple sample orientations.

This tutorial will fit texture of a Nickel coin, based on 5 diffraction images collected with 5 different sample 
orientations. Please see discussion in section IV of the corresponding paper for details: 

L. Lutterotti, R. Vasin & H.-R. Wenk. Rietveld texture analysis from synchrotron diffraction images. 
I. Calibration and basic analysis (2014) Powder Diffr. 29 76-84 doi: 10.1017/S0885715613001346

The dataset consists of 5 tiff images, collected while rotation the sample ω at -40°, -20°, 0°, 20°, 40°. We will 
create 5 datasets, one for each image, and refine the sample texture using the 5 images simulatenously.

2. Datasets

Run MAUD, open your calibration file and save it under a new name, such as  “NCoin_01.par”.

Double-click on the dataset and rename it to “Coin-40”.

In the main MAUD window, duplicate the dataset using “Edit→Duplicate object” menu item. This will 
create a copy of the selected dataset including instrument parameters. Repeat this until you have 5 datasets 
(one for each diffraction image). Then rename the datasets (by double-clicking on its name) to, e.g., 
“Coin-40”, “Coin-20”, “Coin-0”, “Coin+20”, and “Coin+40”.

Select the first dataset named “Coin-40”.  Remove any data that may be left in the “Datafiles” tab, and repeat 
the step to integrate and load the corresponding diffraction images of the coin sample: “Nickel-00178-40.tif”. 
Use the same values for the image size, image rotation (90 degrees counterclockwise, ), center X, center Y 
etc. that you have used for CeO2. Do not change angles such as omega at this point.

After the diffraction image integration is completed and patterns are loaded into MAUD, under “Datafiles” 
tab select all patterns, click “Modify Angles” button and change the ω angle (“New omega =” -40 + omega) 
to account for the sample tilt. For the coin it is appropriate to set the refinement range to 2.5-6.2°, as there are 
no diffraction peaks at lower 2θ values. In “Background function” use 5 polynomial parameters.

MAUD tends to loose instrument parameters in recent version (it’s a bug). Unless your instrument is ok, re-
import your instrument you saved at the end of part 1 (APS-BESSRC-11-ID-C-InclinedReflection.ins in the 
tutorial above).  This is done in the “General” tab of the “Dataset”, in the “Instrument” subwindow.

Repeat these operations for each of the 5 datasets, importing corresponding diffraction images and adjusting 
ω angles accordingly. Note that if you have several datasets then the diffraction patterns shown in all displays 
in the main MAUD window correspond to the currently selected dataset. To see the patterns from any other 
dataset you must select it in “Datasets”. 

If you did well, you should have a dataset called “Coin-40” for which all data files are with ω = 50°, 
“Coin-20” with ω = 70°, “Coin-0” with ω = 0°, “Coin+20” with ω = 110°, and “Coin+40” with ω = 130°.

Save your analysis “NCoin_02.par”.

3. Phase and first refinement

Go to “Phases” tab of the MAUD main window. Remove any phase that is there and create a new object. 
Double-click on it and rename it to “Copper”.

Open the eye icon, and update the crystal parameter:

• Copper is cubic, Fm-3m space group, with a unit cell parameter of 3.6149 Å.
• In the “Structure” tab, add one atom position at (0,0,0) and set the atom type to Cu. Be careful, 

MAUD will set the atom type to Ca by default.

You can now compute the spectrum. Copper peaks should fall at the right 2θ. If not, you did something 
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wrong.

If fact, the alloy in the Nickel coin is not pure nickel, nor copper, but an alloy. Edit the copper phase, go to 
“Structure” tab, select the atom site at (0,0,0). In the “Atom type in this site” sub-panel, add a second atom of 
Ni. Adjust “Partial occupancy” of Cu to 0.75 and of Ni to 0.25.

You can now compute the spectrum again.

You are ready to start with magic. Open the “Analysis → Wizard” 

• Run “Background and scale parameters”, which will fit backgrounds and intensities for each dataset.
• The peaks should be slightly off. Let’s play with crystal parameters. Run the wizard with “Previous 

plus basic phase parameters”, which will optimize the unit cell parameters and B-factors.
• Let’s improve peak shapes, by playing of grain sizes and microstrains. Run the wizard with 

“Previous plus microstructure parameters”, which will optimize the unit cell parameters and B-
factors.

You should now be getting closer to a solution. Save your analysis “NCoin_03.par”.

4. Sample orientation and texture

In “Advanced models” tab select the texture model. Select “E-WIMV” from the drop-down list and press the 
“Options” button next to it. In “E-WIMV options panel” select 10° for “ODF resolution in degrees” (see the 
discussion in section IV of the paper). Click “OK” in the “E-WIMV options panel” to close the window.

To check the texture coverage, first compute the model diffraction patterns (use “Analysis→Compute 
spectra”, or “Calculator” icon), then go to the menu “Graphic→Texture plot”; select the hkl reflection for 
which you want to plot the texture coverage, in the “Pole figure options” panel select “Pole figure coverage” 
and press the “Plot” button. We set the pole figure projection plane parallel to the Nickel coin’s face (as in 
Fig. 2 of the paper) and the corresponding coverage should be similar to the one displayed in Figure 4c in the 
paper.

If not, you may have messed up somewhere, which can be fixed in the MAUD main window. Go to 
“Sample” tab and “edit” current sample. Under “Sample position” change the sample orientation angle ω to 
90° degrees (for instance). This will change the orientation of the sample with respect to conventional 
MAUD reference coordinate system and may help. Try a few values. Try to understand figure 4 in the main 
paper.

With the current version of the tutorial,  ω values should be already set in the dataset.  ω in the sample 
settings should be fine at 0°.

Save your analysis “NCoin_04.par”.

5. Refine coin data, with texture

Go back to the wizard and run “All parameters for texture” and then “Crystal + texture parameters”. The 
correspondence between data and model should improve dramatically. You may run those a few times to see 
if the fit improves.

Save your analysis “NCoin_05.par”.

6. Checking the results

After completion of the refinement, a first step is to check all datasets with the “Plot 2D” display to see if the 
intensity fit looks reasonable (Figure 6 in the paper). You can also do this in a separate window by selecting 
“Graphic→MapPlot of selected dataset” menu. 

It may be also important to see how individual patterns are fitted. This is done by “Editing” a dataset of 
interest. Under “Datafiles” tab select one or several diffraction patterns and press “View” button. Sometimes 
just one or two patterns are fitted poorly, with obviously wrong peak positions, widths or intensities. You 
may remove such “wrong” patterns by unchecking their “Enabled” property in the same window. Repeat the 
refinement without them.
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Check the texture pattern by selecting “Graphic→Texture plot” menu. A new window will appear where it is 
possible to plot selected pole figures hkl, inverse pole figures, strain distributions, etc. on equal area 
projection. 

Select the pole figures to plot (check “Active” next to a set of Miller indices), ensure that “Reconstructed 
intensity” (i.e., pole figures calculated from ODF) and “2D map” options are selected. Then press “Plot” 
button. In a sub-window you have the option to change maximum and minimum values for the pole figure 
plot. You can plot pole figures in color or “Gray shaded”. You may adjust the number of contours to draw 
with a slider in a bottom right part of the window, or smooth with a Gaussian filter (change “Gauss smooth 
width”).

Explore the texture features of MAUD. If you were good a processing, you may compare your results with 
Figure 7 in the companion paper.

You are now a MAUD expert. Improving the fit will involve fine-tweaking, testing new options, and 
understanding the physics behind them. Good luck! With the settings of this version of the tutorial, I find that 
one gets best texture results, in line with the supporting paper, with a better-resolved ODF, with an ODF 
resolution of 6°.

7. Exporting texture for external programs

Even though MAUD offers several options for plotting ODF and pole figures, it is advised to use specialized 
software for further texture processing. In the phase editing window under “Advanced models→E-
WIMV→Options” you can export the ODF (“Export ODF formatted for Beartex”), or pole figures (“Export 
PFs”) as ASCII files for the BEARTEX texture package. 

The exported ODF is always interpolated into 5°x5°x5° cells and can be converted by BEARTEX into a 
binary format for further processing, including smoothing, rotations, representation and physical properties 
calculations. 

You may also want to play with MTEX, which will know how to read BEARTEX files.
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